import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<new_field_name>[^\\-]*$)";
final String string = "id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-423447\n"
+ "id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-6672\n"
+ "id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-4232323";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}