import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<li><a href=\\\"(?:(?!#sequence_only).)*\\\">(.*)</a>";
final String string = " <!DOCTYPE html>\n\n"
+ " <!-- The following setting enables collapsible lists -->\n"
+ " <p>\n"
+ " <a href=\"#human\">Human</a></p>\n\n"
+ " <p class=\"collapse-section\">\n"
+ " <a class=\"collapsed collapse-toggle\" data-toggle=\"collapse\" \n"
+ " href=#mammals>Mammals</a>\n"
+ " <div class=\"collapse\" id=\"mammals\">\n"
+ " <ul>\n"
+ " <li><a href=\"#alpaca\">Alpaca</a>\n"
+ " <li><a href=\"#armadillo\">Armadillo</a>\n"
+ " <li><a href=\"#sequence_only\">Armadillo</a> (sequence only)\n"
+ " <li><a href=\"#baboon\">Baboon</a>\n"
+ " <li><a href=\"#bison\">Bison</a>\n"
+ " <li><a href=\"#bonobo\">Bonobo</a>\n"
+ " <li><a href=\"#brown_kiwi\">Brown kiwi</a>\n"
+ " <li><a href=\"#bushbaby\">Bushbaby</a>\n"
+ " <li><a href=\"#sequence_only\">Bushbaby</a> (sequence only)\n"
+ " <li><a href=\"#cat\">Cat</a>\n"
+ " <li><a href=\"#chimp\">Chimpanzee</a>\n"
+ " <li><a href=\"#chinese_hamster\">Chinese hamster</a>\n"
+ " <li><a href=\"#chinese_pangolin\">Chinese pangolin</a>\n"
+ " <li><a href=\"#cow\">Cow</a>\n"
+ " <li><a href=\"#crab-eating_macaque\">Crab-eating_macaque</a>\n"
+ " <div class=\"gbFooterCopyright\">\n"
+ " © 2017 The Regents of the University of California. All \n"
+ " Rights Reserved.\n"
+ " <br>\n"
+ " <a href=\"https://genome.ucsc.edu/conditions.html\">Conditions of \n"
+ " Use</a>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}