import re
regex = re.compile(r"<li><a href=\"(?:(?!#sequence_only).)*\">(.*)</a>", flags=re.MULTILINE)
test_str = (" <!DOCTYPE html>\n\n"
" <!-- The following setting enables collapsible lists -->\n"
" <p>\n"
" <a href=\"#human\">Human</a></p>\n\n"
" <p class=\"collapse-section\">\n"
" <a class=\"collapsed collapse-toggle\" data-toggle=\"collapse\" \n"
" href=#mammals>Mammals</a>\n"
" <div class=\"collapse\" id=\"mammals\">\n"
" <ul>\n"
" <li><a href=\"#alpaca\">Alpaca</a>\n"
" <li><a href=\"#armadillo\">Armadillo</a>\n"
" <li><a href=\"#sequence_only\">Armadillo</a> (sequence only)\n"
" <li><a href=\"#baboon\">Baboon</a>\n"
" <li><a href=\"#bison\">Bison</a>\n"
" <li><a href=\"#bonobo\">Bonobo</a>\n"
" <li><a href=\"#brown_kiwi\">Brown kiwi</a>\n"
" <li><a href=\"#bushbaby\">Bushbaby</a>\n"
" <li><a href=\"#sequence_only\">Bushbaby</a> (sequence only)\n"
" <li><a href=\"#cat\">Cat</a>\n"
" <li><a href=\"#chimp\">Chimpanzee</a>\n"
" <li><a href=\"#chinese_hamster\">Chinese hamster</a>\n"
" <li><a href=\"#chinese_pangolin\">Chinese pangolin</a>\n"
" <li><a href=\"#cow\">Cow</a>\n"
" <li><a href=\"#crab-eating_macaque\">Crab-eating_macaque</a>\n"
" <div class=\"gbFooterCopyright\">\n"
" © 2017 The Regents of the University of California. All \n"
" Rights Reserved.\n"
" <br>\n"
" <a href=\"https://genome.ucsc.edu/conditions.html\">Conditions of \n"
" Use</a>\n"
" </div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")