const regex = /(?<!\S)T(\d{4})\/(\d{4})(?!\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)T(\\d{4})\\\/(\\d{4})(?!\\S)', 'g')
const str = `Some text T7878/6767 1234AD and some more text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}