$re = '/(?<!\S)T(\d{4})\/(\d{4})(?!\S)/';
$str = 'Some text T7878/6767 1234AD and some more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);