using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<le>\[)?(?P<min>\d\d)\]?(?P<adds>[^\s]+)?";
string input = @"[02]^mc
[02c^
[02c^
49m^";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}