$re = '/(?P<le>\[)?(?P<min>\d\d)\]?(?P<adds>[^\s]+)?/m';
$str = '[02]^mc
[02c^
[02c^
49m^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);