package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\*?[^*]*\*?$`)
var str = `ALLOW:
*string*
*string
string*
string
DENY:
*str*ing*
*str*ing
str*ing*
str*ing
*string**
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}