re = /^\*?[^*]*\*?$/m
str = 'ALLOW:
*string*
*string
string*
string
DENY:
*str*ing*
*str*ing
str*ing*
str*ing
*string**
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end