package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\(NH4\)2SO4\b`)
var str = `Cr2(SO4)3 + (NH4)2SO4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}