$re = '/\b\(NH4\)2SO4\b/m';
$str = 'Cr2(SO4)3 + (NH4)2SO4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);