using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"classes\[theme\][^}]";
string input = @"className={clsx(classes[theme])}
className={`${clsx(classes[theme])}`}
className={classes[theme]}
className={`${classes[theme]}`}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}