package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)classes\[theme\][^}]`)
var str = `className={clsx(classes[theme])}
className={\`${clsx(classes[theme])}\`}
className={classes[theme]}
className={\`${classes[theme]}\`}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}