$re = '/^.*?(\b(?:need(?:ed|ing)?)\b.*(?:(?!\n[ \t]*$)\n.*)*)/m';
$str = 'Anton: I need staff .... now
teste
test
Antor: Ok.
Anton: I need staff .... now
teste
test
Anton: I need staff .... now
teste
test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);