re = /^.*?(\b(?:need(?:ed|ing)?)\b.*(?:(?!\n[ \t]*$)\n.*)*)/m
str = 'Anton: I need staff .... now
teste
test
Antor: Ok.
Anton: I need staff .... now
teste
test
Anton: I need staff .... now
teste
test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end