using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"isaac[\s\S]+?morka";
string input = @"isaac some random string morka morka
isaac things anything morka morka morka isaac letters morka morka";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}