package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)isaac[\s\S]+?morka`)
var str = `isaac some random string morka morka
isaac things anything morka morka morka isaac letters morka morka`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}