package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{2}[1-9]{9}[A-Z]{2}$`)
var str = `AZ123456789AZ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}