$re = '/^[A-Z]{2}[1-9]{9}[A-Z]{2}$/m';
$str = 'AZ123456789AZ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);