package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0|1|2|3|6|100)$`)
var str = `1
2
3
100
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}