$re = '/^(0|1|2|3|6|100)$/m';
$str = '1
2
3
100
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);