using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)\b[^>]+>@(?<username>\w+)<\/\1>";
string input = @"Hello <a href=""#"">@rey</a> how are you doing ?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}