$re = '/<(\w+)\b[^>]+>@(?<username>\w+)<\/\1>/';
$str = 'Hello <a href="#">@rey</a> how are you doing ?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);