import re
regex = re.compile(r"\b[^اويى\W]+\b", flags=re.MULTILINE | re.UNICODE)
test_str = ("تفقدت نظارتي حين استيقظت صباحا فلم اجدها في مكانها وبحثت عنها في كل مكان دون ان اعثر لها علي اثر يا الهي كيف ساخرج اليوم من البيت واواجه النهار \n"
" وتناهي الي من الخارج صوت نقار الخشب فوق جذع شجره قريبه فاسرعت الي الباب وفتحته واذا ضوء النهار يبهر بصري فاغلقت عيني وهتفت ايها النقار اين انت \n"
" وحاولت عبثا ان افتح عيني وانا اقول عفوا لا استطيع ان افتح عيني ان الضوء يعميني")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")