import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"\b[^اويى\W]+\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
تفقدت نظارتي حين استيقظت صباحا فلم اجدها في مكانها وبحثت عنها في كل مكان دون ان اعثر لها علي اثر يا الهي كيف ساخرج اليوم من البيت واواجه النهار
وتناهي الي من الخارج صوت نقار الخشب فوق جذع شجره قريبه فاسرعت الي الباب وفتحته واذا ضوء النهار يبهر بصري فاغلقت عيني وهتفت ايها النقار اين انت
وحاولت عبثا ان افتح عيني وانا اقول عفوا لا استطيع ان افتح عيني ان الضوء يعميني
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)