use strict;
my $str = 'http://user:pass@test.com:8080/example?query#anchor
localhost:8001/test
file:///C:/temp/file.txt
//host:2/path
http://www.foo.com#
scheme:path
ssh://git@github.com';
my $regex = qr/^(?:(?<scheme>[^:\/?#\n]+):(?=\D))?(?:(?:\/\/)?(?:(?:(?<user>[^:\n]*)(?::(?<pass>[^@\n]*))?@)?(?:(?<=.)(?<host>[^[\/:?#\n]+|\[[^]\n]+])(?::(?<port>[^\/:?#\n]+)?)?|(?<host2>(?&host)):(?<port2>(?&port)))|(?<=\/\/)\/)?)?(?<path>[^?#\n]*)(?<query>\?[^#\n]*)?(?<fragment>#.*)?$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}