import Foundation
let pattern = ##"^(?:(?<scheme>[^:\/?#\n]+):(?=\D))?(?:(?:\/\/)?(?:(?:(?<user>[^:\n]*)(?::(?<pass>[^@\n]*))?@)?(?:(?<=.)(?<host>[^[\/:?#\n]+|\[[^]\n]+])(?::(?<port>[^\/:?#\n]+)?)?|(?<host2>(?&host)):(?<port2>(?&port)))|(?<=\/\/)\/)?)?(?<path>[^?#\n]*)(?<query>\?[^#\n]*)?(?<fragment>#.*)?$"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
http://user:pass@test.com:8080/example?query#anchor
localhost:8001/test
file:///C:/temp/file.txt
//host:2/path
http://www.foo.com#
scheme:path
ssh://git@github.com
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)