# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\}\}\}(.*)"
test_str = "{\"body\":{\"records\": {\"time\": \"2020-12-20T13:28:50.2164144Z\",\"MachineGroup\": \"Windows 10\", \"Timestamp\": \"2020-12-20T13:27:18.6679858Z\", \"DeviceName\": \"3242d4e4.dc.democorp.com\", \"ReportId\": 306737}}},\"x-opt-sequence-number\":159959006,\"x-opt-offset\":\"2713650553292728\",\"x-opt-enqueued-time\":1624195823422}"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.