// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\}\}\}(.*)").unwrap();
let string = "{\"body\":{\"records\": {\"time\": \"2020-12-20T13:28:50.2164144Z\",\"MachineGroup\": \"Windows 10\", \"Timestamp\": \"2020-12-20T13:27:18.6679858Z\", \"DeviceName\": \"3242d4e4.dc.democorp.com\", \"ReportId\": 306737}}},\"x-opt-sequence-number\":159959006,\"x-opt-offset\":\"2713650553292728\",\"x-opt-enqueued-time\":1624195823422}";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}