using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<html\b[^><]+?\blang\s*=\s*[""\']\s*\K[^""\']+";
string input = @"<html data-n-head-ssr lang=""en"">
<html lang=""de"">
<html lang=""en"" class=""desktop-view not-mobile-device text-size-normal anon"">";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}