import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<html\\b[^><]+?\\blang\\s*=\\s*[\"\\']\\s*\\K[^\"\\']+";
final String string = "<html data-n-head-ssr lang=\"en\">\n"
+ "<html lang=\"de\">\n"
+ "<html lang=\"en\" class=\"desktop-view not-mobile-device text-size-normal anon\">";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}