package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:\])(.+)`)
var str = `prompt= [1P]Рекомендую надіслати sms на номер 3344 з того номера`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}