$re = '/(?:\])(.+)/iu';
$str = 'prompt= [1P]Рекомендую надіслати sms на номер 3344 з того номера';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);