import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^<>]*:[^<>]*>|(:\\w+:)";
final String string = ":fra: :fra: <:fra:12312312> <a:fra:!232131> :fra::fra:\n"
+ "Some text:fra: Hello:fra::fra::fra: :fra:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}