re = /<[^<>]*:[^<>]*>|(:\w+:)/m
str = ':fra: :fra: <:fra:12312312> <a:fra:!232131> :fra::fra:
Some text:fra: Hello:fra::fra::fra: :fra:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end