import re
regex = re.compile(r"""
(?<li_all>
(?<li_lead_line>\n)?
(?<li_lead_space>^[ \t]*)
(?<list_type_any>
(?:
(?:
(?<list_type_unordered_star>(?&list_unordered_star))
|
(?<list_type_unordered_minus>(?&list_unordered_minus))
|
(?<list_type_unordered_plus>(?&list_unordered_plus))
)
|
(?<list_type_ordered>(?&list_ordered))
)
)
[ \t]*
(?<li_content>(?s:.*?)
(\n{1,2}))
(?= \n*
(
\z
|
\g{li_lead_space}
(?<list_type_any2>
(?:
(?:
(?<list_type_unordered_star2>(?&list_unordered_star))
|
(?<list_type_unordered_minus2>(?&list_unordered_minus))
|
(?<list_type_unordered_plus2>(?&list_unordered_plus))
)
|
(?<list_type_ordered2>(?&list_ordered))
)
)
[ \t]*
)
)
)
(?(DEFINE)
(?<list_unordered_star>
[\*]
(?!
(?:
[ ]?[\*][ ]?
){2,}
)
)
(?<list_unordered_minus>
[\-]
(?!
(?:
[ ]?[\-][ ]?
){2,}
)
)
(?<list_unordered_plus>[\+])
(?<list_ordered>\d+[\.])
)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("* JKL\n"
" 1. JKL-1\n"
" 2. JKL-2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")