re = /(?<li_all>
(?<li_lead_line>\n)?
(?<li_lead_space>^[ \t]*)
(?<list_type_any>
(?:
(?:
(?<list_type_unordered_star>(?&list_unordered_star))
|
(?<list_type_unordered_minus>(?&list_unordered_minus))
|
(?<list_type_unordered_plus>(?&list_unordered_plus))
)
|
(?<list_type_ordered>(?&list_ordered))
)
)
[ \t]*
(?<li_content>(?s:.*?)
(\n{1,2}))
(?= \n*
(
\z
|
\g{li_lead_space}
(?<list_type_any2>
(?:
(?:
(?<list_type_unordered_star2>(?&list_unordered_star))
|
(?<list_type_unordered_minus2>(?&list_unordered_minus))
|
(?<list_type_unordered_plus2>(?&list_unordered_plus))
)
|
(?<list_type_ordered2>(?&list_ordered))
)
)
[ \t]*
)
)
)
(?(DEFINE)
(?<list_unordered_star>
[\*]
(?!
(?:
[ ]?[\*][ ]?
){2,}
)
)
(?<list_unordered_minus>
[\-]
(?!
(?:
[ ]?[\-][ ]?
){2,}
)
)
(?<list_unordered_plus>[\+])
(?<list_ordered>\d+[\.])
)/mx
str = '* JKL
1. JKL-1
2. JKL-2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end