#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi).*?(timer\d{1,3}ms\b)\W+(?!.*\1)\S+"
Local $sString = "fooTimer10ms = timer10ms;" & @CRLF & _
"baaTimer20ms = timer10ms;" & @CRLF & _
"if (DIFF_100MS(dooTimer10ms) >= DOO_TIMEOUT_100MS)" & @CRLF & _
"if (DIFF_100MS(dooTimer10ms) > DOO_TIMEOUT_100MS)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")