import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?(timer\\d{1,3}ms\\b)\\W+(?!.*\\1)\\S+";
final String string = "fooTimer10ms = timer10ms;\n"
+ "baaTimer20ms = timer10ms;\n"
+ "if (DIFF_100MS(dooTimer10ms) >= DOO_TIMEOUT_100MS)\n"
+ "if (DIFF_100MS(dooTimer10ms) > DOO_TIMEOUT_100MS)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}