#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<num>\d{3}) (?P<nom>\w{1,3})\. \[(?P<start>.+?)\] (?P<name>.*) №(?P<_req_id>\d{0,3})$"
Local $sString = "100 I. [С начала] Открытие №" & @CRLF & _
"101 I. [После жюри] Спонсоры №" & @CRLF & _
"102 S. [С точки] Стихия №" & @CRLF & _
"104 K. [С точки] Kim - Mayumi Suzuki-Part of Your World (OST Русалочка) №97" & @CRLF & _
"106 DGJ. [Сразу] Molli, Itami Liska - Code Geass №160" & @CRLF & _
"108 DGJ. [Сразу] Tenletters, Гарка - No Game No Life №107" & @CRLF & _
"110 V. [Сразу~] Sirin, Sandr - Что значит быть человеком (Death Parade, Death Billiards) №137" & @CRLF & _
"112 DSJ. [Сразу] Kaoru - Trinity Blood №34" & @CRLF & _
"114 DSJ. [Сразу] Kanda - D.Gray-man - Hallow №179" & @CRLF & _
"116 DSJ. [Сразу] GEKATA - Brave 10 (10 Храбрецов) №3" & @CRLF & _
"118 DSJ. [Сразу] Nick Satomi - Naruto №143" & @CRLF & _
"120 DSJ. [Сразу] Neko_48 - Touken Ranbu №1" & @CRLF & _
"122 DSJ. [Сразу] Besenok - Little witch academia №130" & @CRLF & _
"124 DSJ. [Сразу] Верука Соль - One Piece №118" & @CRLF & _
"126 DSJ. [Сразу] Fler - Quan Zhi Gao Shou (Аватар короля) №4" & @CRLF & _
"128 T. [С точки] B00-M - BTS-Go-Go №176" & @CRLF & _
"130 DA. [Сразу] Ranmaru - Maiden Rose №123" & @CRLF & _
"132 V. [Сразу~] Rat - Samurai Champloo №149" & @CRLF & _
"132 V. [Сразу~] Rat - Samurai Champloo №149" & @CRLF & _
"134 INK. [Неизвестно] U - Akira Yamaoka-The Promise (OST Silent Hill 2) №11" & @CRLF & _
"136 DSE. [Сразу] Чиби-сан - Harry Potter (Minerva McGonagall) №120" & @CRLF & _
"138 DSE. [Сразу] Toshi-tyan - Game of Thrones №200" & @CRLF & _
"140 DSG. [Сразу] Алекс Крамер - The Witcher 3 - Wild Hunt №175" & @CRLF & _
"142 DSG. [Сразу] РозЭль - Monster Super League №182" & @CRLF & _
"143 DSG. [Сразу] Ihre_Schwermut - Nekopara (Neko Paradise) №117" & @CRLF & _
"144 DSG. [Сразу] Skiv - PokemonGo №69" & @CRLF & _
"148 VC. [Сразу~] Wendy - Vocaloid - Clip Rolling girl №13" & @CRLF & _
"150 DGO. [Сразу] BonSu - Misha Aro, Polina_Chan - Krainar & wild №42" & @CRLF & _
"152 DSO. [С точки] Трюмст - Боевой Шаман №41" & @CRLF & _
"154 DSO. [Сразу] PAIN - Сильмариллион-Саурон №84" & @CRLF & _
"156 DSO. [Сразу] Itami Liska - Pixiv Fantasia - Fallen Kings-Ruri Unsou №52" & @CRLF & _
"201 К. [С точки] Chocola - Aoi Teshima-Niji №" & @CRLF & _
"202 DGJ. [С точки] Kaoru, Родя Светлов - Hetalia №35" & @CRLF & _
"204 DGJ. [Неизвестно] Areshek - Предательство знает мое имя №89" & @CRLF & _
"206 V. [Сразу~] JuliaValter - Если б я могла, то распустила б паруса (Shiki) №111" & @CRLF & _
"208 T. [С точки] LDA - BTS-Blood, Sweat and Fire №177" & @CRLF & _
"209 INK. [Неизвестно] Utakata - Taro Umebayashi-Yuri on ICE №65" & @CRLF & _
"210 DSO. [Сразу] Molli - Принцесса Белоснежка №161" & @CRLF & _
"212 DSO. [С точки] Ayumi Aozora - Loreen-Колибри №128" & @CRLF & _
"214 DU. [Сразу] Infernal Princess - Сатир №85" & @CRLF & _
"216 DU. [Сразу] Лисичка Цай-Шэн - Стрелец №119" & @CRLF & _
"218 DU. [Сразу] Orokamonogatari - Fridgell - Кицунэ №152" & @CRLF & _
"220 DU. [Сразу] Todji - Хацуюмэ №79" & @CRLF & _
"224 DSE. [Сразу] Yami mr.Pingvi - Rise of the Guardians №202" & @CRLF & _
"226 DSE. [Сразу] Bast[et] - Marvel Comics (Black Cat) №93" & @CRLF & _
"228 V. [Сразу~] ALESSA - Good bye my friend №39" & @CRLF & _
"230 KA. [С точки] Олег Кот - ONE OK ROCK-Heartache №195" & @CRLF & _
"232 DSJ. [Сразу] sauronCat - Magi - The Labyrinth of Magic №6" & @CRLF & _
"234 DSJ. [Сразу] Eva Heine - Герои Шести Цветов №183" & @CRLF & _
"236 DSJ. [Сразу] Neko mimi - Sailor Moon №186" & @CRLF & _
"238 DSJ. [Сразу] Umino Akari - Kami-sama Hajimemashita №94" & @CRLF & _
"242 DSJ. [Сразу] Onii chan - Крестовый поход Хроно №165" & @CRLF & _
"244 VC. [Сразу~] Step Up - Bleach - Bleach Live Opening №135" & @CRLF & _
"246 DSG. [С точки] Ирина Лонер - League of Legends №134" & @CRLF & _
"248 DSG. [Сразу] DisasterRus - Halo №185" & @CRLF & _
"250 DSG. [Сразу] Paprika - Undertale №53" & @CRLF & _
"252 DGG. [Сразу] JET SET - МАТЕО, Савич - Silent Hill №83" & @CRLF & _
"254 DSG. [Сразу] Itami Liska - Fate Grand Order №51" & @CRLF & _
"256 VC. [Сразу~] Fransuaza Stein - Scissors Crown - Alice №25" & @CRLF & _
"258 T. [С точки] GLOOMY DANCE TEAM - BLACKPINK-Whistle+As If It's Your Last №109" & @CRLF & _
"260 DGE. [Сразу] Конда, An Tiff - Tutenstein №127" & @CRLF & _
"262 DGE. [С точки] Табун ежат - Джин-сама, Апекс - Samurai Jack №81" & @CRLF & _
"264 DGE. [С точки] Alien frost, Pinky - Rise of the Guardians №7" & @CRLF & _
"266 DGE. [Сразу] Black General, Murph - Atlantis - The Lost Empire №203" & @CRLF & _
"268 KA. [Неизвестно] U - Shizuru Otaka-Natsu wo Mite Ita (OST Hotarubi no Mori e) №12" & @CRLF & _
"270 V. [Сразу~] Neironezumi - ren'ai-kankei (Honobono Log) №144" & @CRLF & _
"272 T. [С точки] Bread Ducks - Sistar-Shake it №36" & @CRLF & _
"274 KA. [С точки] Patricia Heather, Юлия - Sound Horizon-Shinzou wo Sasageyo (Attack on Titan OP) №204" & @CRLF & _
"302 DA. [Сразу] Ranmaru, Molli - Восточные сказки №162" & @CRLF & _
"304 DA. [Сразу] Glitch Squad - Tora, Kim, Комар - Dota 2 №96" & @CRLF & _
"306 K. [С точки] Just_Kurinai - u's-LOVELESS WORLD (OST Love Live! School Idol Project) №189" & @CRLF & _
"308 V. [Сразу~] Kido - Life (Твоя апрельская ложь) №54" & @CRLF & _
"310 T. [С точки] REDTeam - EXO-Monster №129" & @CRLF & _
"312 KA. [Сразу] ТО Хикари - Ytakata, Konran - Lacrimosa-Kalafina (OST Kuroshitsuji) №191" & @CRLF & _
"318 DSJ. [Сразу] Tenshi Neko - Dagashi Kashi (Магазинчик сладостей) №29" & @CRLF & _
"320 DSJ. [Сразу] ALESSA - Haikyuu!! №46" & @CRLF & _
"322 DSJ. [Сразу] Admiral Puni - D.N. Angel №187" & @CRLF & _
"324 DSJ. [Сразу] Lenny - Shaman King №19" & @CRLF & _
"326 DSJ. [Сразу] Mikki Moon - Tokyo Ghoul №68" & @CRLF & _
"330 DU. [С точки] Bast[et] - Японский фольклор (Neko) №91" & @CRLF & _
"332 DU. [Сразу] Fortune's Fool - Morana Virs, Суоди - Исо-онна, Фуна-юрэй №66" & @CRLF & _
"334 DU. [Сразу] Molli - Кицунэ №159" & @CRLF & _
"335 I. [Акайо! Сейчас!] Интермедия 9.3 - Гром №" & @CRLF & _
"336 DGJ. [Сразу] Kroliczek - Neko_48, Fler, GEKATA - Алые сердца Корё №9" & @CRLF & _
"340 DA. [Сразу] Missadefunctorum - Weyland, Куро Тачибано - Mejibray №174" & @CRLF & _
"342 DA. [Сразу] Факел - Духи любят пошалить №95" & @CRLF & _
"344 INK. [Неизвестно] U - Nao Hiiragi-Requiem (OST Tasogare Otome x Amnesia) №10" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")