$re = '/^(?P<num>\d{3}) (?P<nom>\w{1,3})\. \[(?P<start>.+?)\] (?P<name>.*) №(?P<_req_id>\d{0,3})$/m';
$str = '100 I. [С начала] Открытие №
101 I. [После жюри] Спонсоры №
102 S. [С точки] Стихия №
104 K. [С точки] Kim - Mayumi Suzuki-Part of Your World (OST Русалочка) №97
106 DGJ. [Сразу] Molli, Itami Liska - Code Geass №160
108 DGJ. [Сразу] Tenletters, Гарка - No Game No Life №107
110 V. [Сразу~] Sirin, Sandr - Что значит быть человеком (Death Parade, Death Billiards) №137
112 DSJ. [Сразу] Kaoru - Trinity Blood №34
114 DSJ. [Сразу] Kanda - D.Gray-man - Hallow №179
116 DSJ. [Сразу] GEKATA - Brave 10 (10 Храбрецов) №3
118 DSJ. [Сразу] Nick Satomi - Naruto №143
120 DSJ. [Сразу] Neko_48 - Touken Ranbu №1
122 DSJ. [Сразу] Besenok - Little witch academia №130
124 DSJ. [Сразу] Верука Соль - One Piece №118
126 DSJ. [Сразу] Fler - Quan Zhi Gao Shou (Аватар короля) №4
128 T. [С точки] B00-M - BTS-Go-Go №176
130 DA. [Сразу] Ranmaru - Maiden Rose №123
132 V. [Сразу~] Rat - Samurai Champloo №149
132 V. [Сразу~] Rat - Samurai Champloo №149
134 INK. [Неизвестно] U - Akira Yamaoka-The Promise (OST Silent Hill 2) №11
136 DSE. [Сразу] Чиби-сан - Harry Potter (Minerva McGonagall) №120
138 DSE. [Сразу] Toshi-tyan - Game of Thrones №200
140 DSG. [Сразу] Алекс Крамер - The Witcher 3 - Wild Hunt №175
142 DSG. [Сразу] РозЭль - Monster Super League №182
143 DSG. [Сразу] Ihre_Schwermut - Nekopara (Neko Paradise) №117
144 DSG. [Сразу] Skiv - PokemonGo №69
148 VC. [Сразу~] Wendy - Vocaloid - Clip Rolling girl №13
150 DGO. [Сразу] BonSu - Misha Aro, Polina_Chan - Krainar & wild №42
152 DSO. [С точки] Трюмст - Боевой Шаман №41
154 DSO. [Сразу] PAIN - Сильмариллион-Саурон №84
156 DSO. [Сразу] Itami Liska - Pixiv Fantasia - Fallen Kings-Ruri Unsou №52
201 К. [С точки] Chocola - Aoi Teshima-Niji №
202 DGJ. [С точки] Kaoru, Родя Светлов - Hetalia №35
204 DGJ. [Неизвестно] Areshek - Предательство знает мое имя №89
206 V. [Сразу~] JuliaValter - Если б я могла, то распустила б паруса (Shiki) №111
208 T. [С точки] LDA - BTS-Blood, Sweat and Fire №177
209 INK. [Неизвестно] Utakata - Taro Umebayashi-Yuri on ICE №65
210 DSO. [Сразу] Molli - Принцесса Белоснежка №161
212 DSO. [С точки] Ayumi Aozora - Loreen-Колибри №128
214 DU. [Сразу] Infernal Princess - Сатир №85
216 DU. [Сразу] Лисичка Цай-Шэн - Стрелец №119
218 DU. [Сразу] Orokamonogatari - Fridgell - Кицунэ №152
220 DU. [Сразу] Todji - Хацуюмэ №79
224 DSE. [Сразу] Yami mr.Pingvi - Rise of the Guardians №202
226 DSE. [Сразу] Bast[et] - Marvel Comics (Black Cat) №93
228 V. [Сразу~] ALESSA - Good bye my friend №39
230 KA. [С точки] Олег Кот - ONE OK ROCK-Heartache №195
232 DSJ. [Сразу] sauronCat - Magi - The Labyrinth of Magic №6
234 DSJ. [Сразу] Eva Heine - Герои Шести Цветов №183
236 DSJ. [Сразу] Neko mimi - Sailor Moon №186
238 DSJ. [Сразу] Umino Akari - Kami-sama Hajimemashita №94
242 DSJ. [Сразу] Onii chan - Крестовый поход Хроно №165
244 VC. [Сразу~] Step Up - Bleach - Bleach Live Opening №135
246 DSG. [С точки] Ирина Лонер - League of Legends №134
248 DSG. [Сразу] DisasterRus - Halo №185
250 DSG. [Сразу] Paprika - Undertale №53
252 DGG. [Сразу] JET SET - МАТЕО, Савич - Silent Hill №83
254 DSG. [Сразу] Itami Liska - Fate Grand Order №51
256 VC. [Сразу~] Fransuaza Stein - Scissors Crown - Alice №25
258 T. [С точки] GLOOMY DANCE TEAM - BLACKPINK-Whistle+As If It\'s Your Last №109
260 DGE. [Сразу] Конда, An Tiff - Tutenstein №127
262 DGE. [С точки] Табун ежат - Джин-сама, Апекс - Samurai Jack №81
264 DGE. [С точки] Alien frost, Pinky - Rise of the Guardians №7
266 DGE. [Сразу] Black General, Murph - Atlantis - The Lost Empire №203
268 KA. [Неизвестно] U - Shizuru Otaka-Natsu wo Mite Ita (OST Hotarubi no Mori e) №12
270 V. [Сразу~] Neironezumi - ren\'ai-kankei (Honobono Log) №144
272 T. [С точки] Bread Ducks - Sistar-Shake it №36
274 KA. [С точки] Patricia Heather, Юлия - Sound Horizon-Shinzou wo Sasageyo (Attack on Titan OP) №204
302 DA. [Сразу] Ranmaru, Molli - Восточные сказки №162
304 DA. [Сразу] Glitch Squad - Tora, Kim, Комар - Dota 2 №96
306 K. [С точки] Just_Kurinai - u\'s-LOVELESS WORLD (OST Love Live! School Idol Project) №189
308 V. [Сразу~] Kido - Life (Твоя апрельская ложь) №54
310 T. [С точки] REDTeam - EXO-Monster №129
312 KA. [Сразу] ТО Хикари - Ytakata, Konran - Lacrimosa-Kalafina (OST Kuroshitsuji) №191
318 DSJ. [Сразу] Tenshi Neko - Dagashi Kashi (Магазинчик сладостей) №29
320 DSJ. [Сразу] ALESSA - Haikyuu!! №46
322 DSJ. [Сразу] Admiral Puni - D.N. Angel №187
324 DSJ. [Сразу] Lenny - Shaman King №19
326 DSJ. [Сразу] Mikki Moon - Tokyo Ghoul №68
330 DU. [С точки] Bast[et] - Японский фольклор (Neko) №91
332 DU. [Сразу] Fortune\'s Fool - Morana Virs, Суоди - Исо-онна, Фуна-юрэй №66
334 DU. [Сразу] Molli - Кицунэ №159
335 I. [Акайо! Сейчас!] Интермедия 9.3 - Гром №
336 DGJ. [Сразу] Kroliczek - Neko_48, Fler, GEKATA - Алые сердца Корё №9
340 DA. [Сразу] Missadefunctorum - Weyland, Куро Тачибано - Mejibray №174
342 DA. [Сразу] Факел - Духи любят пошалить №95
344 INK. [Неизвестно] U - Nao Hiiragi-Requiem (OST Tasogare Otome x Amnesia) №10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);