import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:/[^/?&#\\s]+)*/?$";
final String string = "api/v1\n"
+ "/api/v1\n"
+ "/api/2v1/21/\n"
+ "/api/blah/v1/\n"
+ "/api/ether/v1//\n"
+ "/api/23v1///";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}