re = /^(?:\/[^\/?&#\s]+)*\/?$/m
str = 'api/v1
/api/v1
/api/2v1/21/
/api/blah/v1/
/api/ether/v1//
/api/23v1///'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end