const regex = /(?=#\B)([\S\s]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=#\\B)([\\S\\s]+)', 'gm')
const str = `# www.admitme.app
# Carlo Baxter
# resumes in 15 minutes`;
const subst = `$1 #`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);