re = /(?=#\B)([\S\s]+)/m
str = '# www.admitme.app
# Carlo Baxter
# resumes in 15 minutes'
subst = '$1 #'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result