using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[а-яА-Я]+-\d+\/\d+";
string input = @"Ол-22/2021";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}