$re = '/[а-яА-Я]+-\d+\/\d+/mi';
$str = 'Ол-22/2021';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);