#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\w(?=\w{4,}$)"
Local $sString = "TESTTESTTEST"
Local $sSubst = "###"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)