import Foundation
let pattern = #"\w(?=\w{4,}$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"TESTTESTTEST"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ####"###"####
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)