import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+).*?(?=\\1|$)";
final String string = "Auth= bigben.com\\\\Dileja\n"
+ "Server = ringring.com\n"
+ "Config = teststringA[XXXXXXXXXXXXXXXXXXX...until EOL\n"
+ "X]Auth= dingdong.com\\\\Debyyy\n"
+ "Server = testtest.com\n"
+ "Config = teststringB";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}